// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"([^"]+.jpg)""#).unwrap();
let string = "<a href=\"/index.html\">Home</a>
<a href=\"xmas-greeting-dolly.jpg\">xmas-greeting-dolly.jpg</a>
<a href=\"privacy.html\"><font color=\"#003366\">View WavList.com 's Privacy Policy</font></a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}