$re = '/"([^"]+.jpg)"/m';
$str = '<a href="/index.html">Home</a>
<a href="xmas-greeting-dolly.jpg">xmas-greeting-dolly.jpg</a>
<a href="privacy.html"><font color="#003366">View WavList.com \'s Privacy Policy</font></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);