const regex = /"([^"]+.jpg)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^"]+.jpg)"', 'gm')
const str = `<a href="/index.html">Home</a>
<a href="xmas-greeting-dolly.jpg">xmas-greeting-dolly.jpg</a>
<a href="privacy.html"><font color="#003366">View WavList.com 's Privacy Policy</font></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}