#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[Cat]"
Local $sString = "The regular expression above will every character that is either a captial "C", a lower case "a", or a lower case "t". The square brackets are used to indicate a list of characters to match (like saying "I want to find any of the following items: 'C', 'a' or 't'"). To see all matches, click "preg_match_all" to the right (it's a long list)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")