package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[Cat]`)
var str = `The regular expression above will every character that is either a captial "C", a lower case "a", or a lower case "t". The square brackets are used to indicate a list of characters to match (like saying "I want to find any of the following items: 'C', 'a' or 't'"). To see all matches, click "preg_match_all" to the right (it's a long list).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}