using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[Cat]";
string input = @"The regular expression above will every character that is either a captial ""C"", a lower case ""a"", or a lower case ""t"". The square brackets are used to indicate a list of characters to match (like saying ""I want to find any of the following items: 'C', 'a' or 't'""). To see all matches, click ""preg_match_all"" to the right (it's a long list).";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}