import Foundation
let pattern = #"[Cat]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"The regular expression above will every character that is either a captial "C", a lower case "a", or a lower case "t". The square brackets are used to indicate a list of characters to match (like saying "I want to find any of the following items: 'C', 'a' or 't'"). To see all matches, click "preg_match_all" to the right (it's a long list)."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)