$re = '/[Cat]/';
$str = 'The regular expression above will every character that is either a captial "C", a lower case "a", or a lower case "t". The square brackets are used to indicate a list of characters to match (like saying "I want to find any of the following items: \'C\', \'a\' or \'t\'"). To see all matches, click "preg_match_all" to the right (it\'s a long list).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);