using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span class=""*QuellonStartSession""*>(.+?)<\/span>(.+?)<span class=""*QuellonEndSession""*>.+?<\/span>";
string input = @"<span class=""QuellonStartSession"">FirstSession</span><span class=""QuellonStartSession"">SecondSession</span>SomeContent<span class=""QuellonEndSession"">EndSecondSession</span>SomeContent...<span class=""QuellonEndSession"">EndFirstSession</span> ....Content...<span class=""QuellonStartSession"">SomeSession</span>Content<span class=""QuellonEndSession"">EndSomeSession</span>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}