const regex = /<span class=""*QuellonStartSession""*>(.+?)<\/span>(.+?)<span class=""*QuellonEndSession""*>.+?<\/span>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span class=""*QuellonStartSession""*>(.+?)<\\\/span>(.+?)<span class=""*QuellonEndSession""*>.+?<\\\/span>', 'gi')
const str = `<span class="QuellonStartSession">FirstSession</span><span class="QuellonStartSession">SecondSession</span>SomeContent<span class="QuellonEndSession">EndSecondSession</span>SomeContent...<span class="QuellonEndSession">EndFirstSession</span> ....Content...<span class="QuellonStartSession">SomeSession</span>Content<span class="QuellonEndSession">EndSomeSession</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}