re = /<span class=""*QuellonStartSession""*>(.+?)<\/span>(.+?)<span class=""*QuellonEndSession""*>.+?<\/span>/i
str = '<span class="QuellonStartSession">FirstSession</span><span class="QuellonStartSession">SecondSession</span>SomeContent<span class="QuellonEndSession">EndSecondSession</span>SomeContent...<span class="QuellonEndSession">EndFirstSession</span> ....Content...<span class="QuellonStartSession">SomeSession</span>Content<span class="QuellonEndSession">EndSomeSession</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end