// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<span class=""*QuellonStartSession""*>(.+?)<\/span>(.+?)<span class=""*QuellonEndSession""*>.+?<\/span>"#).unwrap();
let string = "<span class=\"QuellonStartSession\">FirstSession</span><span class=\"QuellonStartSession\">SecondSession</span>SomeContent<span class=\"QuellonEndSession\">EndSecondSession</span>SomeContent...<span class=\"QuellonEndSession\">EndFirstSession</span> ....Content...<span class=\"QuellonStartSession\">SomeSession</span>Content<span class=\"QuellonEndSession\">EndSomeSession</span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}