package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<span class=""*QuellonStartSession""*>(.+?)<\/span>(.+?)<span class=""*QuellonEndSession""*>.+?<\/span>`)
var str = `<span class="QuellonStartSession">FirstSession</span><span class="QuellonStartSession">SecondSession</span>SomeContent<span class="QuellonEndSession">EndSecondSession</span>SomeContent...<span class="QuellonEndSession">EndFirstSession</span> ....Content...<span class="QuellonStartSession">SomeSession</span>Content<span class="QuellonEndSession">EndSomeSession</span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}