import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span class=\"\"*QuellonStartSession\"\"*>(.+?)<\\/span>(.+?)<span class=\"\"*QuellonEndSession\"\"*>.+?<\\/span>";
final String string = "<span class=\"QuellonStartSession\">FirstSession</span><span class=\"QuellonStartSession\">SecondSession</span>SomeContent<span class=\"QuellonEndSession\">EndSecondSession</span>SomeContent...<span class=\"QuellonEndSession\">EndFirstSession</span> ....Content...<span class=\"QuellonStartSession\">SomeSession</span>Content<span class=\"QuellonEndSession\">EndSomeSession</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}