#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([0-9,]*([3-9][0-9]|2[5-9]),?[0-9]{3})\s?)(\s19)$"
Local $sString = "25,000 19" & @CRLF & _
"24,999 19" & @CRLF & _
"25,000 109" & @CRLF & _
"25000 19" & @CRLF & _
"24999 19" & @CRLF & _
"25000 109" & @CRLF & _
"1,509,126,999 19"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")