const regex = /^(([0-9,]*([3-9][0-9]|2[5-9]),?[0-9]{3})\s?)(\s19)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([0-9,]*([3-9][0-9]|2[5-9]),?[0-9]{3})\\s?)(\\s19)$', 'gm')
const str = `25,000 19
24,999 19
25,000 109
25000 19
24999 19
25000 109
1,509,126,999 19`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}