// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([0-9,]*([3-9][0-9]|2[5-9]),?[0-9]{3})\s?)(\s19)$").unwrap();
let string = "25,000 19
24,999 19
25,000 109
25000 19
24999 19
25000 109
1,509,126,999 19";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}