using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([0-9,]*([3-9][0-9]|2[5-9]),?[0-9]{3})\s?)(\s19)$";
string input = @"25,000 19
24,999 19
25,000 109
25000 19
24999 19
25000 109
1,509,126,999 19";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}