re = /^(([0-9,]*([3-9][0-9]|2[5-9]),?[0-9]{3})\s?)(\s19)$/m
str = '25,000 19
24,999 19
25,000 109
25000 19
24999 19
25000 109
1,509,126,999 19'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end