package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([0-9,]*([3-9][0-9]|2[5-9]),?[0-9]{3})\s?)(\s19)$`)
var str = `25,000 19
24,999 19
25,000 109
25000 19
24999 19
25000 109
1,509,126,999 19`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}