import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([0-9,]*([3-9][0-9]|2[5-9]),?[0-9]{3})\\s?)(\\s19)$";
final String string = "25,000 19\n"
+ "24,999 19\n"
+ "25,000 109\n"
+ "25000 19\n"
+ "24999 19\n"
+ "25000 109\n"
+ "1,509,126,999 19";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}