#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "1\.2\.3\.4\.(\d+) = WORDS: (?|"([^"]*)|([^:]*))"
Local $sString = "2.3.8.2.2.1.2.3.4.12345 = WORDS: "String to capture"" & @CRLF & _
"2.3.8.2.2.1.2.3.4.12345 = """
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")