$re = '/1\.2\.3\.4\.(\d+) = WORDS: (?|"([^"]*)|([^:]*))/';
$str = '2.3.8.2.2.1.2.3.4.12345 = WORDS: "String to capture"
2.3.8.2.2.1.2.3.4.12345 = ""';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);