package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`1\.2\.3\.4\.(\d+) = WORDS: (?|"([^"]*)|([^:]*))`)
var str = `2.3.8.2.2.1.2.3.4.12345 = WORDS: "String to capture"
2.3.8.2.2.1.2.3.4.12345 = ""`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}