import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "1\\.2\\.3\\.4\\.(\\d+) = WORDS: (?|\"([^\"]*)|([^:]*))";
final String string = "2.3.8.2.2.1.2.3.4.12345 = WORDS: \"String to capture\"\n"
+ "2.3.8.2.2.1.2.3.4.12345 = \"\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}