const regex = /1\.2\.3\.4\.(\d+) = WORDS: (?|"([^"]*)|([^:]*))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('1\\.2\\.3\\.4\\.(\\d+) = WORDS: (?|"([^"]*)|([^:]*))', '')
const str = `2.3.8.2.2.1.2.3.4.12345 = WORDS: "String to capture"
2.3.8.2.2.1.2.3.4.12345 = ""`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}