// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"1\.2\.3\.4\.(\d+) = WORDS: (?|"([^"]*)|([^:]*))"#).unwrap();
let string = "2.3.8.2.2.1.2.3.4.12345 = WORDS: \"String to capture\"
2.3.8.2.2.1.2.3.4.12345 = \"\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}