import Foundation
let pattern = #"1\.2\.3\.4\.(\d+) = WORDS: (?|"([^"]*)|([^:]*))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2.3.8.2.2.1.2.3.4.12345 = WORDS: "String to capture"
2.3.8.2.2.1.2.3.4.12345 = ""
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}