#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*)\/(.*)-(\d{4})(?:-(.*))?"
Local $sString = "Fooliser/Greatest Hits-1234-whatever stuffy stuff with 7777 digits" & @CRLF & _
"Foo4444Bar/Greatest Hits-2345-whatever stuffy stuff with 7777 digits" & @CRLF & _
"Bazqux/Best-of-2000-Hits-3456-whatever stuffy stuff with 7777 digits" & @CRLF & _
"Fooliser/Greatest Hits-1234" & @CRLF & _
"Foo4444Bar/Greatest Hits-2345" & @CRLF & _
"Bazqux/Best-of-2000-Hits-3456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")