const regex = /(.*)\/(.*)-(\d{4})(?:-(.*))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\\/(.*)-(\\d{4})(?:-(.*))?', 'g')
const str = `Fooliser/Greatest Hits-1234-whatever stuffy stuff with 7777 digits
Foo4444Bar/Greatest Hits-2345-whatever stuffy stuff with 7777 digits
Bazqux/Best-of-2000-Hits-3456-whatever stuffy stuff with 7777 digits
Fooliser/Greatest Hits-1234
Foo4444Bar/Greatest Hits-2345
Bazqux/Best-of-2000-Hits-3456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}