re = /(.*)\/(.*)-(\d{4})(?:-(.*))?/
str = 'Fooliser/Greatest Hits-1234-whatever stuffy stuff with 7777 digits
Foo4444Bar/Greatest Hits-2345-whatever stuffy stuff with 7777 digits
Bazqux/Best-of-2000-Hits-3456-whatever stuffy stuff with 7777 digits
Fooliser/Greatest Hits-1234
Foo4444Bar/Greatest Hits-2345
Bazqux/Best-of-2000-Hits-3456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end