# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)\/(.*)-(\d{4})(?:-(.*))?"
test_str = ("Fooliser/Greatest Hits-1234-whatever stuffy stuff with 7777 digits\n"
"Foo4444Bar/Greatest Hits-2345-whatever stuffy stuff with 7777 digits\n"
"Bazqux/Best-of-2000-Hits-3456-whatever stuffy stuff with 7777 digits\n"
"Fooliser/Greatest Hits-1234\n"
"Foo4444Bar/Greatest Hits-2345\n"
"Bazqux/Best-of-2000-Hits-3456")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.