using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)\/(.*)-(\d{4})(?:-(.*))?";
string input = @"Fooliser/Greatest Hits-1234-whatever stuffy stuff with 7777 digits
Foo4444Bar/Greatest Hits-2345-whatever stuffy stuff with 7777 digits
Bazqux/Best-of-2000-Hits-3456-whatever stuffy stuff with 7777 digits
Fooliser/Greatest Hits-1234
Foo4444Bar/Greatest Hits-2345
Bazqux/Best-of-2000-Hits-3456";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}