// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)\/(.*)-(\d{4})(?:-(.*))?").unwrap();
let string = "Fooliser/Greatest Hits-1234-whatever stuffy stuff with 7777 digits
Foo4444Bar/Greatest Hits-2345-whatever stuffy stuff with 7777 digits
Bazqux/Best-of-2000-Hits-3456-whatever stuffy stuff with 7777 digits
Fooliser/Greatest Hits-1234
Foo4444Bar/Greatest Hits-2345
Bazqux/Best-of-2000-Hits-3456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}