import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)\\/(.*)-(\\d{4})(?:-(.*))?";
final String string = "Fooliser/Greatest Hits-1234-whatever stuffy stuff with 7777 digits\n"
+ "Foo4444Bar/Greatest Hits-2345-whatever stuffy stuff with 7777 digits\n"
+ "Bazqux/Best-of-2000-Hits-3456-whatever stuffy stuff with 7777 digits\n"
+ "Fooliser/Greatest Hits-1234\n"
+ "Foo4444Bar/Greatest Hits-2345\n"
+ "Bazqux/Best-of-2000-Hits-3456";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}