using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img[^<]+class=[\""'][^<]*\s*thumbnail\s*[^<]*[\""'][^<]+>)";
string input = @"<p><img class="" asdf thumbnail as"" src=""abc.jpg"" height=""83"" width=""131""></p></p><p><img src=""def.jpg"" class=""thumbnail"" height=""83"" width=""131""></p>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}