const regex = /(<img[^<]+class=[\"'][^<]*\s*thumbnail\s*[^<]*[\"'][^<]+>)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<img[^<]+class=[\\"\'][^<]*\\s*thumbnail\\s*[^<]*[\\"\'][^<]+>)', 'ig')
const str = `<p><img class=" asdf thumbnail as" src="abc.jpg" height="83" width="131"></p></p><p><img src="def.jpg" class="thumbnail" height="83" width="131"></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}