package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(<img[^<]+class=[\"'][^<]*\s*thumbnail\s*[^<]*[\"'][^<]+>)`)
var str = `<p><img class=" asdf thumbnail as" src="abc.jpg" height="83" width="131"></p></p><p><img src="def.jpg" class="thumbnail" height="83" width="131"></p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}