re = /(<img[^<]+class=[\"'][^<]*\s*thumbnail\s*[^<]*[\"'][^<]+>)/i
str = '<p><img class=" asdf thumbnail as" src="abc.jpg" height="83" width="131"></p></p><p><img src="def.jpg" class="thumbnail" height="83" width="131"></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end