// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)(<img[^<]+class=[\"'][^<]*\s*thumbnail\s*[^<]*[\"'][^<]+>)"#).unwrap();
let string = "<p><img class=\" asdf thumbnail as\" src=\"abc.jpg\" height=\"83\" width=\"131\"></p></p><p><img src=\"def.jpg\" class=\"thumbnail\" height=\"83\" width=\"131\"></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}