#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)[^A-Za-z0-9.@/ _\xe9\x{e8}-]"
Local $sString = "J'utilise la commande suivante pour supprimer tous les caractères spéciaux des noms de fichiers à l'exception de ".", "@", "/", " ", "_", "-", "é" et "è"."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")