use strict;
my $str = 'J\'utilise la commande suivante pour supprimer tous les caractères spéciaux des noms de fichiers à l\'exception de ".", "@", "/", " ", "_", "-", "é" et "è".';
my $regex = qr~[^A-Za-z0-9.@/ _\xe9\x{e8}-]~up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}