package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^A-Za-z0-9.@/ _\xe9\x{e8}-]`)
var str = `J'utilise la commande suivante pour supprimer tous les caractères spéciaux des noms de fichiers à l'exception de ".", "@", "/", " ", "_", "-", "é" et "è".`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}