import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^A-Za-z0-9.@/ _\\xe9\\x{e8}-]";
final String string = "J'utilise la commande suivante pour supprimer tous les caractères spéciaux des noms de fichiers à l'exception de \".\", \"@\", \"/\", \" \", \"_\", \"-\", \"é\" et \"è\".";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}