using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^A-Za-z0-9.@/ _\xe9\x{e8}-]";
string input = @"J'utilise la commande suivante pour supprimer tous les caractères spéciaux des noms de fichiers à l'exception de ""."", ""@"", ""/"", "" "", ""_"", ""-"", ""é"" et ""è"".";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}