// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)[^A-Za-z0-9.@/ _\xe9\x{e8}-]").unwrap();
let string = "J'utilise la commande suivante pour supprimer tous les caractères spéciaux des noms de fichiers à l'exception de \".\", \"@\", \"/\", \" \", \"_\", \"-\", \"é\" et \"è\".";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}