#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^alp:[^:]+:([^:]+).*$"
Local $sString = "mfast_acquired_theresasale" & @CRLF & _
"alp:psch_nb_b2b:thisisthekeyword:thisistheoccassion" & @CRLF & _
"alp:psch_nb:paid keyword:rewardsclub" & @CRLF & _
"alp:psch_nb:gifts:sale" & @CRLF & _
"alp:psch_things:keyword_phrase "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")