const regex = /^alp:[^:]+:([^:]+).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^alp:[^:]+:([^:]+).*$', 'gm')
const str = `mfast_acquired_theresasale
alp:psch_nb_b2b:thisisthekeyword:thisistheoccassion
alp:psch_nb:paid keyword:rewardsclub
alp:psch_nb:gifts:sale
alp:psch_things:keyword_phrase `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}