$re = '/^alp:[^:]+:([^:]+).*$/m';
$str = 'mfast_acquired_theresasale
alp:psch_nb_b2b:thisisthekeyword:thisistheoccassion
alp:psch_nb:paid keyword:rewardsclub
alp:psch_nb:gifts:sale
alp:psch_things:keyword_phrase ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);