import re
regex = re.compile(r"^alp:[^:]+:([^:]+).*$", flags=re.MULTILINE)
test_str = ("mfast_acquired_theresasale\n"
"alp:psch_nb_b2b:thisisthekeyword:thisistheoccassion\n"
"alp:psch_nb:paid keyword:rewardsclub\n"
"alp:psch_nb:gifts:sale\n"
"alp:psch_things:keyword_phrase ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")